aboutsummaryrefslogtreecommitdiffstats
path: root/initscripts.spec
diff options
context:
space:
mode:
Diffstat (limited to 'initscripts.spec')
-rw-r--r--initscripts.spec179
1 files changed, 141 insertions, 38 deletions
diff --git a/initscripts.spec b/initscripts.spec
index 0e850d2f..2a0f7133 100644
--- a/initscripts.spec
+++ b/initscripts.spec
@@ -1,6 +1,6 @@
Summary: The inittab file and the /etc/init.d scripts
Name: initscripts
-Version: 9.41
+Version: 9.50
# ppp-watch is GPLv2+, everything else is GPLv2
License: GPLv2 and GPLv2+
Group: System Environment/Base
@@ -18,6 +18,8 @@ Requires: bash >= 3.0
Requires: sysvinit-tools >= 2.87-5
Conflicts: systemd < 23-1
Conflicts: systemd-units < 23-1
+Conflicts: lvm2 < 2.02.98-3
+Conflicts: dmraid < 1.0.0.rc16-18
Requires: systemd
Requires: iproute, /sbin/arping, findutils
# Not strictly required, but nothing else requires it
@@ -30,6 +32,7 @@ Requires(pre): /usr/sbin/groupadd
Requires(post): /sbin/chkconfig, coreutils
Requires(preun): /sbin/chkconfig
BuildRequires: glib2-devel popt-devel gettext pkgconfig
+Provides: /sbin/service
%description
The initscripts package contains the basic system scripts used to boot
@@ -84,26 +87,26 @@ chown root:utmp /var/log/wtmp /var/run/utmp /var/log/btmp
chmod 664 /var/log/wtmp /var/run/utmp
chmod 600 /var/log/btmp
-/sbin/chkconfig --add network
-/sbin/chkconfig --add netconsole
+/usr/sbin/chkconfig --add network
+/usr/sbin/chkconfig --add netconsole
if [ $1 -eq 1 ]; then
- /bin/systemctl daemon-reload > /dev/null 2>&1 || :
+ /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
fi
%preun
if [ $1 = 0 ]; then
- /sbin/chkconfig --del network
- /sbin/chkconfig --del netconsole
+ /usr/sbin/chkconfig --del network
+ /usr/sbin/chkconfig --del netconsole
fi
%triggerun -- initscripts < 7.62
-/sbin/chkconfig --del random
-/sbin/chkconfig --del rawdevices
+/usr/sbin/chkconfig --del random
+/usr/sbin/chkconfig --del rawdevices
exit 0
%postun
if [ $1 -ge 1 ]; then
- /bin/systemctl daemon-reload > /dev/null 2>&1 || :
+ /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
fi
%clean
@@ -117,10 +120,10 @@ rm -rf $RPM_BUILD_ROOT
%config(noreplace) /etc/sysconfig/netconsole
%config(noreplace) /etc/sysconfig/readonly-root
/etc/sysconfig/network-scripts/ifdown
-/sbin/ifdown
+/usr/sbin/ifdown
/etc/sysconfig/network-scripts/ifdown-post
/etc/sysconfig/network-scripts/ifup
-/sbin/ifup
+/usr/sbin/ifup
%dir /etc/sysconfig/console
%dir /etc/sysconfig/modules
/etc/sysconfig/network-scripts/network-functions
@@ -159,31 +162,32 @@ rm -rf $RPM_BUILD_ROOT
%dir /etc/rwtab.d
/etc/statetab
%dir /etc/statetab.d
-/lib/systemd/fedora-*
-/lib/systemd/system/*
-%config(noreplace) /etc/inittab
+/usr/lib/systemd/fedora-*
+/usr/lib/systemd/system/*
+/etc/inittab
%dir /etc/rc.d
%dir /etc/rc.d/rc[0-9].d
/etc/rc[0-9].d
%dir /etc/rc.d/init.d
/etc/rc.d/init.d/*
%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/rc.d/rc.local
+%config(noreplace) /etc/sysctl.conf
/usr/lib/sysctl.d/00-system.conf
+/etc/sysctl.d/99-sysctl.conf
%exclude /etc/profile.d/debug*
/etc/profile.d/*
/usr/sbin/sys-unconfig
-/sbin/setsysfont
-/bin/ipcalc
-/bin/usleep
+/usr/bin/ipcalc
+/usr/bin/usleep
%attr(4755,root,root) /usr/sbin/usernetctl
-/sbin/consoletype
-/sbin/genhostid
-/sbin/sushell
-%attr(2755,root,root) /sbin/netreport
-/lib/udev/rules.d/*
-/lib/udev/rename_device
-/sbin/service
-/sbin/ppp-watch
+/usr/sbin/consoletype
+/usr/sbin/genhostid
+/usr/sbin/sushell
+%attr(2755,root,root) /usr/sbin/netreport
+/usr/lib/udev/rules.d/*
+/usr/lib/udev/rename_device
+/usr/sbin/service
+/usr/sbin/ppp-watch
%{_mandir}/man*/*
%dir %attr(775,root,root) /var/run/netreport
%dir /etc/ppp
@@ -203,8 +207,9 @@ rm -rf $RPM_BUILD_ROOT
%ghost %attr(0664,root,utmp) /var/log/wtmp
%ghost %attr(0664,root,utmp) /var/run/utmp
%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/crypttab
-%dir /lib/tmpfiles.d
-/lib/tmpfiles.d/initscripts.conf
+%dir /usr/lib/tmpfiles.d
+/usr/lib/tmpfiles.d/initscripts.conf
+%dir /usr/libexec/initscripts
%dir /usr/libexec/initscripts/legacy-actions
%files -n debugmode
@@ -213,6 +218,104 @@ rm -rf $RPM_BUILD_ROOT
/etc/profile.d/debug*
%changelog
+* Tue Sep 03 2013 Lukas Nykryn <lnykryn@redhat.com> - 9.50-1
+- ipcalc: support RFC3021 (#997271)
+- symlink /etc/sysctl.conf -> /etc/sysctl.d/
+- man: only action specified in LSB are redirected to systemd
+- service: filter actions that are not supported by systemctl in service (#947823)
+- install_bonding_driver: drop check for existing device (#991335)
+- consider IPV6INIT undefined as YES
+- don't care about network filesystems
+
+* Fri Jul 12 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.48-1
+- man: add systemd man pages to service.8 "see also" section
+- add possibility to set domainname through /etc/sysconfig/network
+- rename_device: don't wait for lock with lower permissions
+- 256term.csh: remove quotes around variable (#979796)
+- drop useless variables from /etc/sysconfig/init
+- readonly-root: rpcidmapd restart is not needed anymore
+- ifup-eth: print error only if arping is really called (#974603)
+- readonly-root: Add /var/lib/samba to rwtab
+
+* Fri May 31 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.47-1
+- network-functions: to determine state of nscd check socket not lock (#960779)
+- sysconfig.txt advised saslauthd -a instad of -v
+- update translations from transifex
+- drop translation for other initscripts
+- tweak ifup/ifdown usage and man page (#961917)
+- ctrl-alt-delete.target is provided by systemd package
+- remove some defaults from arch specific sysctl.conf
+- readonly-root: remount rpc_pipefs if readonly-root is used
+- service: mention legacy actions and systemctl redirection in man page
+
+* Fri Apr 12 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.46-1
+- add /var/lib/NetworkManager
+- add ipip6 tunneling support (#928232, raorn@raorn.name)
+- bonding: set master up before slaves
+- set net.ipv6.conf.SYSCTLDEVICE.autoconf in ifup-ipv6
+- ifdown: don't call nmcli on interface that is alread down
+- remove some defaults from sysctl.conf (move to systemd)
+- call flush addresses with scope global
+- service: action should not be empty when calling legacy-actions (#947817)
+- ifup-eth: ignore arping errors (#928379)
+- replace tunctl with ip tuntap (#947875)
+- reload sysctl settings for vlans on ifup
+- try dhcpv6 after v4 failed (#846618)
+
+* Fri Mar 15 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.45-2
+- provides /sbin/service
+
+* Fri Mar 15 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.45-1
+- turn on symlink protections in sysctl (#922030)
+- add systemd-random-seed.service to Before= in fedora-readonly.service (#888615)
+- mention rule6 files in sysconfig.txt
+- skip nmcli for wireless device (#863707)
+- remove config-noreplace from /etc/inittab (#627474)
+- remount-rootfs.service got renamed to systemd-remount-fs.service
+- compile netreport and usernetctl with full RELRO and PIE (#853178)
+- move stuff directly to /usr (#905492)
+- Remove NETWORKING_IPV6 from sysconfig.txt (#918622)
+- fix greps to correctly handle comments and quotation
+
+* Wed Feb 20 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.44-1
+- limit udev rule for network renaming (#907365, mschmidt@redhat.com)
+- fix path for arpwatch, seems to be in /var/lib on Fedora 18
+- fix the path for lvm cache, there is no file /etc/lvm/.cache ( but there is one /etc/lvm/cache )
+- fix path for dhcpd, is /var/lib/dhcpd since 2005 ( see 31cdb58df77 on the dhcp package git )
+- fix the patch for apache modules in rwtab, that are now in /var/cache/httpd
+- remove no longer used directory ( at least in Fedora ), hald is deprecated,
+ /var/tux cannot be found and xend seems to use a subdirectory of /var/lib/xen
+- correct the path for puppet directory in /etc/rwtab, now use /var/lib/puppet by default
+- allow passing -F from /.autorelabel to fixfiles when relabeling system (#904279)
+- correctly detect Open vSwitch device types
+- clear DEVICE and TYPE variables before every iteration (#902463)
+- sets BONDING_OPTS before interface is brougth up
+- check an IP address for existence in ifup-alias (#852005)
+- sync FSF address with GPL 2 text.
+- fix rpmlint's spaces vs tabs warning.
+- fix bogus %changelog dates.
+- build with $RPM_LD_FLAGS.
+- use -sf, not -s. (#901827)
+- add /usr/libexec/initscripts to file list (#894475)
+- rename term256 to 256term (glob sort) (#849429)
+- readd missing shebang. (#885821)
+- migrate even further away from /etc/sysconfig/network for hostname, and /etc/sysconfig/i18n.
+
+* Fri Dec 7 2012 Bill Nottingham <notting@redhat.com> - 9.43-1
+- 60-net.rules: explicitly set the interface name (#870859)
+- ifup-eth: set firewall zone before ifup-ipv6 for DHCPv6 (#802415)
+- migrate to /etc/locale.conf, /etc/vconsole.conf (#881923)
+- rename_device: fix bogus locking
+- fix wireless device detection for kernel 3.6 (#875328)
+- drop fedora-storage-init, fedora-wait-storage (<prajinoha@redhat.com>)
+
+* Wed Oct 31 2012 Bill Nottingham <notting@redhat.com> - 9.42-1
+- Halloween release!
+- add a default /etc/sysctl.conf that describes how to change values, and where the defaults now live. (#760254)
+- translation updates
+- fedora-autorelabel: don't pass -F to fixfiles (#863662, <dwalsh@redhat.com>)
+- fix calling of firewall-cmd in ifup-post/ifdown-post (<jpopelka@redhat.com>)
+
* Fri Oct 5 2012 Bill Nottingham <notting@redhat.com> - 9.41-1
- debugmode: MALLOC_CHECK_ is not thread safe. Don't enable it by default (#853175)
- Add support for 256 color terminals (<pbrady@redhat.com>)
@@ -1426,7 +1529,7 @@ rm -rf $RPM_BUILD_ROOT
* Thu Oct 07 2004 Florian La Roche <Florian.LaRoche@redhat.de>
- change /etc/sysctl.conf to not allow source routed packets per default
-* Fri Oct 6 2004 Bill Nottingham <notting@redhat.com> - 7.88-1
+* Wed Oct 6 2004 Bill Nottingham <notting@redhat.com> - 7.88-1
- fix requires
* Tue Oct 5 2004 Dan Walsh <dwalsh@redhat.com> - 7.87-1
@@ -1524,7 +1627,7 @@ rm -rf $RPM_BUILD_ROOT
* Tue Aug 24 2004 Karsten Hopp <karsten@redhat.de> 7.68-1
- execute zfcfconf.sh if available (mainframe)
-* Mon Aug 20 2004 Jason Vas Dias <jvdias@redhat.com> 7.67-1
+* Mon Aug 23 2004 Jason Vas Dias <jvdias@redhat.com> 7.67-1
- fix change_resolv_conf: if pre-existing /etc/resolv.conf
- non-existent or empty, replace with new file contents.
@@ -1557,7 +1660,7 @@ rm -rf $RPM_BUILD_ROOT
- fix nfs unmounting (#129765)
- fix URL (#129433)
-* Tue Aug 11 2004 Jason Vas Dias <jvdias@redhat.com> 7.61-1
+* Wed Aug 11 2004 Jason Vas Dias <jvdias@redhat.com> 7.61-1
- fix for bug 120093: add PERSISTENT_DHCLIENT option to ifcfg files
* Tue Aug 3 2004 Karsten Hopp <karsten@redhat.de> 7.60-1
@@ -1901,7 +2004,7 @@ rm -rf $RPM_BUILD_ROOT
- loop checking for network link state, don't unilterally wait five
seconds
-* Fri Dec 14 2002 Karsten Hopp <karsten@redhat.de> 6.99-1
+* Sat Dec 14 2002 Karsten Hopp <karsten@redhat.de> 6.99-1
- remove call to /sbin/update for S/390, too
* Wed Dec 11 2002 Bill Nottingham <notting@redhat.com> 6.98-1
@@ -2254,7 +2357,7 @@ rm -rf $RPM_BUILD_ROOT
* Mon Jul 16 2001 Than Ngo <than@redhat.com>
- fix country_code for ISDN
-* Tue Jul 9 2001 Bill Nottingham <notting@redhat.com>
+* Mon Jul 9 2001 Bill Nottingham <notting@redhat.com>
- fix '--check'
- prereq sh-utils (#43065)
- fix some invocations of reboot/halt (#45966)
@@ -2270,7 +2373,7 @@ rm -rf $RPM_BUILD_ROOT
- Fix up kernel versioning on binary-only modules (S390)
- don't use newt scripts on S390 console
-* Sat Jul 01 2001 Trond Eivind Glomsrød <teg@redhat.com>
+* Sun Jul 01 2001 Trond Eivind Glomsrød <teg@redhat.com>
- reenable pump, but make sure dhcpcd is the default. This
way, upgrades of systems without dhcpcd has a better chance at
working.
@@ -2508,7 +2611,7 @@ rm -rf $RPM_BUILD_ROOT
* Tue Aug 15 2000 Nalin Dahyabhai <nalin@redhat.com>
- be more careful about creating files in netreport (#16164)
-* Sat Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
+* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
- move documentation for the DEMAND and IDLETIMEOUT values to the right
section of sysconfig.txt
@@ -2577,7 +2680,7 @@ rm -rf $RPM_BUILD_ROOT
* Sun Jul 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
- don't use tail
-* Thu Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
+* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
- add support for USB controllers and HID devices
(mice, keyboards)
@@ -2619,7 +2722,7 @@ rm -rf $RPM_BUILD_ROOT
- fix lang.csh, again (oops)
- use /poweroff, /halt to determine whether to poweroff
-* Thu Apr 14 2000 Bill Nottingham <notting@redhat.com>
+* Fri Apr 14 2000 Bill Nottingham <notting@redhat.com>
- fix testing of RESOLV_MODS (which shouldn't be used anyways)
* Tue Apr 04 2000 Ngo Than <than@redhat.de>
@@ -2723,7 +2826,7 @@ rm -rf $RPM_BUILD_ROOT
- better signal handling in ppp-watch
- yet another attempt to fix those rare PAP/CHAP problems
-* Sat Nov 28 1999 Bill Nottingham <notting@redhat.com>
+* Sun Nov 28 1999 Bill Nottingham <notting@redhat.com>
- impressive. Three new features, three new bugs.
* Mon Nov 22 1999 Michael K. Johnson <johnsonm@redhat.com>
@@ -2996,7 +3099,7 @@ rm -rf $RPM_BUILD_ROOT
* Tue Nov 10 1998 Michael K. Johnson <johnsonm@redhat.com>
- handle new linuxconf output for ipaliases
-* Mon Oct 15 1998 Erik Troan <ewt@redhat.com>
+* Thu Oct 15 1998 Erik Troan <ewt@redhat.com>
- fixed raid start stuff
- added raidstop to halt