summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..9882c14
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/python
+from distutils.core import setup
+import re
+
+verpat = re.compile("VERSION *= *\"(.*)\"")
+data = open("bm").read()
+m = verpat.search(data)
+if not m:
+ sys.exit("error: can't find VERSION")
+VERSION = m.group(1)
+
+setup(name="bm",
+ version = VERSION,
+ description = "BuildManager - rpm package building helper",
+ author = "Gustavo Niemeyer",
+ author_email = "niemeyer@conectiva.com",
+ url = "http://moin.conectiva.com.br/BuildManager",
+ license = "GPL",
+ long_description =
+"""\
+BuildManager, or bm, is a program that wraps and extends rpm while building
+packages. Its features allow one to batch process thousand of RPMS at once,
+controling logs, rpm and srpm moving, filtering the list of files, ignoring
+given packages, completely cleaning the build directories, and many other
+features.
+""",
+ packages = ["BuildManager"],
+ scripts = ["bm", "bmclean"],
+ )