aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 9e00c6a..b10f56e 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -55,7 +55,7 @@ print $FH "\n#endif\n";
close($FH);
my $workaround;
-if (-e '/etc/redhat-release' && $cfg{modversion} =~ /4.11/) {
+if (! -e '/etc/mageia-release' && -e '/etc/redhat-release' && $cfg{modversion} =~ /4.11/) {
$workaround = '-DPATCHED_RH';
}
my $ccflags = join(' ', '-Wall -Wextra -fno-strict-aliasing', $cfg{cflags}, "-DRPM_VERSON=$cfg{modversion}", $workaround);